cloudinit.d is registered on pypi and can thus be installed with easy_install. If you have python 2.5 or greater installed on your system the easiest way to install cloudinitd is:

easy_install cloudinitd

Install from git

If you would like to download the source code and install from a git checkout you can run the following command set:

git clone git://
cd cloudinitd
python install

python 2.5 or greater is required.

Installing on CentOS 5.5 or RHEL 5

Because CentOS 5.5 does not come with python 2.5 the installation requires a few additional sets:

rpm -Uvh
yum -y install python26-devel python26-distribute.noarch gcc
easy_install-2.6 cloudinitd
cloudinitd --help